Nerding in parallel

Did I promise to give an update if and when I worked on the portable Steambox project again? I did? Well, here you go! We worked on it! And ALSO on something else.

Again, things came down to power. This project needs a battery pack that can power both the screen AND the motherboard, and at different voltages and amperage. We’ve got some bits and bobs that should have done the job, but none quite did All The Things. So, I went back to my thinking at the start of this project, and looked for a consumer battery pack that would do what was needed. And, after an email chat with a representative, I found the Anker PowerCore AC. I picked it up and… didn’t test it. I’d given the power cords to my partner in crime, so to speak, and he was out of the country for work. Well, last week, he came back.

Whatever tells the Anker power pack to increase the amperage to support faster charging isn’t happening with the screen. It’s getting the 5 volts and 100 milliamps, but isn’t getting the quick charge IQ goodness. So, the screen tries to turn on, fails to get enough, and turns off. So, we needed to find a way to check if the battery pack could put out what was advertised.

Tech mess

My friend set up the following power chain: Anker A/C port, router plug, power-over-ethernet injector, RJ45 cable, step-down converter, D/C cord into screen. And it worked! The screen turned on and stayed on! So we know for a fact that the power supply can do the needful, at least out of the A/C port. Now we need to figure out a way to either trigger the battery pack to engage its fast charging, or combine the power from two USB ports to support the screen. We’ll see which way it goes.

Tech mess

The other project is re-purposing an old Dell PowerEdge server into a moderately useful gaming box. It’s currently got one Xeon quad core processor running at about 2.5 GHz, and has a slot for another. It’s got 8 gigs of RAM, and can go up to a whole lot more. My friend had thrown in a 5 year old video card with 1 gig of VRAM, that had sat in its box since he picked it up. It’s got a 500 gig hard drive, but it’s one that came with the server and is a bit slow. Windows 10 runs on it, and runs pretty well, which wasn’t a surprise. It’s done a really good job of scaling down to old hardware since its release, and hasn’t reversed that trend, which I’m thankful for.

Our first test was Minecraft, cranked to full everything, and it ran smooth as butter. Next, we installed Everquest II, a game that the end user (my friend’s wife) plays, and I hadn’t played in about seven years. My login still worked! My characters were still there! I had a succession of “what the crap” moments, and tooled around the winter area in which I spawned, and figured out that anything over “Balanced” graphics quality wasn’t going to be smooth. But! The game worked! For old time’s sake, I let off a PENITENT KICK! and took a photo.

EQ2

Leave a Reply

Your email address will not be published. Required fields are marked *